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Layers Management Extension for SketchUp 

Layers Management Tool Overview 
SketchUp is a great tool and one that seems ideally suited for woodworking or more correctly the 

woodworker. However, like many shop tools we use, there is often missing capability and we 

woodworkers build jigs and fixtures to overcome those shortcomings. SketchUp is no different. 

Fortunately, the designers of SketchUp provided a wonderful method for filling the voids in its 

functionality: the SketchUp Ruby API provides a means for anyone to write Ruby programming language 

scripts to extend SketchUp’s functionality. Because Layers is such an important tool to the woodworker, 

one he/she needs to design and document custom furniture, and because SketchUp has missing 

functionality to manage Layers, I wrote this script (tool). 

There are two personalities to the Layers Management tool: Layer0 Warning, which attempts to keep 

one out of trouble by warning the user when he/she changes the active layer to other than Layer0; Layer 

Tools which are a tool set used to create layers and make them all visible, invisible or reversed. 

Locating Your Plugins Folder 
You don’t need to know where your Plugins folder is to install Layers Management, but you might want 

to know where it is to verify you installed it correctly. If you don’t know where it is you can find it using 

the Ruby Console. To open the Ruby Console go to the Window menu and click on Ruby Console. The 

Ruby Console will appear. In the white area at the bottom copy and paste or type the following line 

exactly: 

Sketchup.find_support_file("Plugins/") 

It should look like Figure 1. Press the 

Enter key on the keyboard and you will 

see the results shown at the top of the 

next page, Figure 2. Note that I had to 

drag the right side of the window to 

enlarge it so the folder location would 

appear all on one line. Copy and paste 

the folder location and save it for future 

reference. You might also want to create 

a shortcut on your desktop pointing to 

the Plugins folder. 

 Figure 1 - The Ruby statement to locate the Plugins folder. 
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Figure 2 - The second line is the location of the SketchUp Plugins folder. 

Installation of Layers Management 

IMPORTANT: Follow These Installation Instructions Carefully 

Look in your Plugins folder and see if you have either or both add_hidden_layer.rb or 

layers_show_hide_all.rb installed and if you do delete these files.  

There are several ways of installing Layers Management. If you obtain Layers Management from the 

Extensions Warehouse you can automatically install it from there. If you downloaded layers_2.3.rbz 

from some other source such as my website use the following procedure depending on your SketchUp 

version. 

SketchUp Versions 8 and 2013 through 2016 Make or Pro 
Download the layers_2.3.rbz file to a folder where you can easily find it i.e. a folder you know the 

location of. Your desktop is a good place.  

1. We recommend logging into your computer as an admin before installing any Ruby scripts. This 

will make the installation go more smoothly and ensure that files get installed in the proper 

places. 

2. Select Window > Preferences (Microsoft Windows) or SketchUp > Preferences (Mac OS X). The 

Preferences dialog box is displayed. 

3. Click on Extensions. The Extensions panel is displayed. 

4. Click on the Install Extension button. The Open dialog box is displayed. 

5. Locate the Ruby zip file to install (.rbz) and highlight it using the cursor. 

6. Click on the Open button. 

7. You will see a message asking if you trust the author of this Ruby script. If you do click the Yes 

button. (Hint: I am trustable.) 

8. You will see a message announcing successful installation. Click OK. 

9. In the Extensions panel be sure Layers Manager is checked to enable it. See Figure 3. 

http://www.srww.com/downloads/Layers%20Management/layers_2.3.rbz
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SketchUp Version 2017 Make or Pro 
Download the layers_2.3.rbz file to a folder where you can easily find it i.e. a folder you know the 

location of. Your desktop is a good place.  

1. We recommend logging into your computer as an admin before installing any Ruby scripts. This 

will make the installation go more smoothly and ensure that files get installed in the proper 

places. 

2. Select Window > Extension Manager (Microsoft Windows) or SketchUp > Preferences (Mac OS 

X). The Extension Manager dialog box is displayed. 

3. Click on the Install Extension button. The Open dialog box is displayed. 

4. Locate the Ruby zip file to install (.rbz) and highlight it using the cursor. 

5. Click on the Open button. 

6. The Extension Manager list will change to include Layers Manager (you may have to scroll to see 

it) and should be Enabled on the right. 

7. To the right of the blue Enabled button is a right arrow. Click on it and it will change to a down 

arrow. Below it is information regarding Layers Manager. The version number should be 2.3. 

After Installation Check The Following 

 

Figure 3 - Extensions Panel with Layers Manager checked. 

When completed be sure to check that a layers folder and a layers.rb file reside in the Plugins folder. See 

Figure 4. 

If SketchUp is open, close it. On the Mac make sure all model windows are closed and indeed the 

application is closed. Now reopen SketchUp. Go to the View menu and be sure Layer0 Warning is 

checked as shown in Figure 5. 

http://www.srww.com/downloads/Layers%20Management/layers_2.3.rbz
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Lastly, go to menu View/Toolbars and check (select) Layer Tools. This will place the Layer Tools toolbar 

somewhere on the SketchUp window (or possibly even on your desktop area outside the SketchUp 

window). You can drag and drop it anywhere you want. 

Reporting Problems with Layers Management 
I hope this script improves your efficiency a little. Please report all bugs and strange behavior to: 

jpz@srww.com 

 

Figure 4 - The contents of my Plugins folder showing the layers folder and layers.rb file. 

Layer0 Warning 
I have taught SketchUp to a large number of students, mostly through my live courses, DVDs and book. 

Based on their feedback, and conversations I have had with other instructors, it is clear there are two 

dominant areas students struggle with. 

1. The stickiness of SketchUp is stumbling block number one. Anytime two primitives touch they 

become connected. This is useful if those primitives are meant to touch, such as when they are 

pieces of the same part. But if they are pieces of different parts this stickiness creates huge 

problems. The solution is for students to download and follow the Six Rules for Modeling in 

mailto:jpz@srww.com
http://www.srww.com/blog/wp-content/uploads/2011/02/Six%20Rules%20for%20Modeling%20in%20SketchUp.pdf
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SketchUp. I have found that students who follow these rules, particularly Rule 4 - As soon as a 

part takes 3D shape make it a component - escape this problem entirely. 

2. The second largest stumbling block is the accidental or intentional violation of Rule 2 - Layer0 

(Layer Zero) should always be active when modeling. To see the kind of havoc this can cause 

view the Primitives, Components & Layers tutorial. To help students avoid this problem I have 

added functionality to the Layers Management Tool which will warn of a Rule 2 violation. 

 

 

Figure 5 - View menu with Layer0 Warning shown enabled when checked. 

The intent of Layer0 Warning is to let a beginner know when he/she is about to change from active 

Layer0 (Layer Zero) to another layer. By default Layer0 Warning is enabled the first time layers.rb is 

installed. From then on the last state of Layer0 Warning will be stored upon closing SketchUp and 

recalled upon subsequently opening SketchUp. 

If you wish to disable the warning go to menu View/Layer0 Warning and uncheck it. 

If you wish to re-enable Layer0 Warning go to menu View/Layer0 Warning and check it. 

http://www.srww.com/blog/wp-content/uploads/2011/02/Six%20Rules%20for%20Modeling%20in%20SketchUp.pdf
http://www.srww.com/blog/?p=1419
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When enabled Layer0 Warning will monitor the active layer; the layer with the radio button selected to 

the left of its name. If a layer other than Layer0 is made active, a warning message will appear as shown 

here. 

 

Notice that the message tells you which layer will become the active layer and also how to disable the 

warning. If a layer other than Layer0 is active and then Layer0 is made active, no warning is given 

because Layer0 is the desired layer for modeling. Note that this is just a warning; Layer0 Warning will 

not prohibit the layer change. The user must decide if this change was intentional or accidental. If the 

latter the user must manually change back to Layer0. Click OK to close the warning message box. 

I should point out that I am an experienced SketchUp user and I never disable Layer0 warning. It is too 

easy to accidentally change the active layer and get into serious modeling trouble. 

Layer Tools 
Depending on how you use SketchUp you may find these tools helpful. I tend to use a lot of layers and 

scenes in my models; especially when it comes to dimensioning them. For example, I typically use one 

scene per dimensioning view and add those dimensions and components to a matching layer. If you add 

layers via the  icon in the Window/Layers dialog box a new layer is added but visible to all existing 

and new scenes. This required going back to old scenes and making the new layer invisible. If the 

number of scenes is large this is a time consuming task. 

Many moons ago I discovered add_hidden_layer.rb coded by Jim Foltz. It allowed me to add a layer 

hidden to all current and future scenes. It was a life savior, but still had a few minor problems; there was 

no tool icon and I really wanted to add a layer visible to the current scene but hidden in all others. 

Another little annoyance is that SketchUp provided no tool to make all layers visible or all invisible, both 

of which I found I could use frequently. That was when I discovered layers_show_hide_all.rb coded by 

Madcello. It was perfect except it also had no tool icons. 
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To make my life easier, I combined these tools into one Ruby script adding the tool icons and the visible 

layer for the current scene functionality. The new Ruby script is called layers.rb and embeds both the 

Layer Tools and Layer0 Warning functionality. 

The Layer Tools has the following Menu Items: 

 View/Add Visible Layer 

 View/Add Invisible Layer 

 View/Show All Layers 

 View/Complement All Layers 

 View/Hide All Layers 

In addition a Layer Tools toolbar is available under View/Toolbars and contains four icons which can be 

used instead of the menu items above. You make this toolbar visible by choosing View/Toolbars/Layer 

Tools. The toolbar looks as follows: 

 

Description of toolbar icons: 

 Add Visible Layer icon adds a visible layer to the current scene, but invisible to all existing and new 

scenes. Add Visible Layer always adds a layer to the Layers list but its Visible check box is unchecked in 

all scenes EXCEPT the scene that was active (scene tab is blue) when you added the layer. If there are no 

scenes, a layer is added and its Visible check box is CHECKED. 

 Add Invisible Layer icon adds an invisible layer to all existing and new scenes. Add Invisible Layer 

always adds a layer to the Layers list but its Visible check box is unchecked in all scenes. If there are no 

scenes, a layer is added and its Visible check box is CHECKED. 

 Show All Layers icon makes all layers visible. 

 Complement All Layers icon reverses the visibility of all layers except the active layer which should 

always be Layer0. 

 Hide All Layers icon makes all layers invisible except the active layer which should always be 

Layer0. 
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